R1# ip route 0 0 0 0 FastEthernet0/0 R2# show run



tải về 18.29 Kb.
Chuyển đổi dữ liệu10.08.2016
Kích18.29 Kb.


R1# ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
R2# show run
interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
ip nat inside
!
interface FastEthernet1/0
ip address 192.168.24.1 255.255.255.0
ip nat outside
!
ip nat inside source list 1 interface FastEthernet1/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet1/0
ip route 192.168.0.0 255.255.255.0 192.168.2.1
ip route 192.168.1.0 255.255.255.0 192.168.2.1
access-list 1 permit any
R3# show run
interface FastEthernet1/1
ip address 192.168.34.1 255.255.255.0
ip nat outside
!
interface FastEthernet0/0
ip address 192.168.2.3 255.255.255.0
ip nat inside
!
ip nat inside source list 1 interface FastEthernet1/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet1/1
ip route 192.168.0.0 255.255.255.0 192.168.2.1
ip route 192.168.1.0 255.255.255.0 192.168.2.1
access-list 1 permit any

Cấu hình xong hết thử từ PC0 và PC1 ping tới mạng 4 thành công là ok.
Note: Vì sao ta cần phải NAT? trên R2 và R3
-Đó là do packet có thể đi về R1 từ 2 đường. Nat giúp cho R4 trả lời những gói từ R1 đúng đường. Đi đường nào về đường nấy chứ không đi đường R3 mà về đường R4.
-Một số thiết bị cân bằng tải theo gói thì đừng nên xài vì một bên đi đường này, một bên đi đường kia thì có một số ứng dụng không chạy được. Nên tốt nhất ta dùng cân bằng tải theo đích như trường hợp dưới đây.


Yêu cầu 1.

PC0 đi qua R2 tới mạng 4.4.4.0/24


PC1 đi qua R3 tới mạng 4.4.4.0/24

R1(config)#access-list 12 permit 192.168.0.0 0.0.0.255
R1(config)#route-map PC0-R2 per
R1(config-route-map)#match ip address 12
R1(config-route-map)#set ip next-hop 192.168.2.2
R1(config)#int f1/0
R1(config-if)#ip policy route-map PC0-R2


R1(config)#access-list 13 permit 192.168.1.0 0.0.0.255
R1(config)#route-map PC1-R3 permit
R1(config-route-map)#match ip address 13
R1(config-route-map)#set ip next-hop 192.168.2.3
R1(config)#int f1/1
R1(config-if)#ip policy route-map PC1-R3

R1#show route-map
route-map PC0-R2, permit, sequence 10
Match clauses:
ip address (access-lists): 12
Set clauses:
ip next-hop 192.168.2.2
Policy routing matches: 44 packets, 4878 bytes
route-map PC1-R3, permit, sequence 10
Match clauses:
ip address (access-lists): 13
Set clauses:
ip next-hop 192.168.2.3
Policy routing matches: 25 packets, 2850 bytes


Sau đó trên R1 ta bật lệnh debug ip policy để xem kết quả

R1#debug ip policy


Policy routing debugging is on
R1#
*Dec 2 14:55:03.895: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4, len 60, FIB policy match
*Dec 2 14:55:03.895: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4, len 60, policy match
*Dec 2 14:55:03.899: IP: route map PC0-R2, item 10, permit
*Dec 2 14:55:03.899: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4 (FastEthernet0/0), len 60, policy routed
*Dec 2 14:55:03.903: IP: FastEthernet1/0 to FastEthernet0/0 192.168.2.2
R1#
*Dec 2 14:55:09.391: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4, len 60, FIB policy match
*Dec 2 14:55:09.391: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4, g=192.168.2.2, len 60, FIB policy routed
*Dec 2 14:55:09.395: CEF: CEF switched to FastEthernet0/0
*Dec 2 14:55:10.379: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4, len 60, FIB policy match
*Dec 2 14:55:10.379: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4, g=192.168.2.2, len 60, FIB policy routed
R1#
*Dec 2 14:55:11.387: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4, len 60, FIB policy match
*Dec 2 14:55:11.387: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4, g=192.168.2.2, len 60, FIB policy routed
R1#
*Dec 2 14:55:23.455: IP: s=192.168.1.1 (FastEthernet1/1), d=4.4.4.4, len 100, FIB policy match
*Dec 2 14:55:23.455: IP: s=192.168.1.1 (FastEthernet1/1), d=4.4.4.4, len 100, policy match
*Dec 2 14:55:23.459: IP: route map PC1-R3, item 10, permit
*Dec 2 14:55:23.459: IP: s=192.168.1.1 (FastEthernet1/1), d=4.4.4.4 (FastEthernet0/0), len 100, policy routed
*Dec 2 14:55:23.463: IP: FastEthernet1/1 to FastEthernet0/0 192.168.2.3
R1#
*Dec 2 14:55:25.427: IP: s=192.168.1.1 (FastEthernet1/1), d=4.4.4.4, len 100, FIB policy match
*Dec 2 14:55:25.427: IP: s=192.168.1.1 (FastEthernet1/1), d=4.4.4.4, g=192.168.2.3, len 100, FIB policy routed
R1#
*Dec 2 14:55:27.451: IP: s=192.168.1.1 (FastEthernet1/1), d=4.4.4.4, len 100, FIB policy match
*Dec 2 14:55:27.451: IP: s=192.168.1.1 (FastEthernet1/1), d=4.4.4.4, g=192.168.2.3, len 100, FIB policy routed
*Dec 2 14:55:27.519: IP: s=192.168.1.1 (FastEthernet1/1), d=4.4.4.4, len 100, FIB policy match
*Dec 2 14:55:27.519: IP: s=192.168.1.1 (FastEthernet1/1), d=4.4.4.4, g=192.168.2.3, len 100, FIB policy routed
*Dec 2 14:55:27.555: IP: s=192.168.1.1 (FastEthernet1/1), d=4.4.4.4, len 100, FIB policy match
*Dec 2 14:55:27.555: IP: s=192.168.1.1 (FastEthernet1/1), d=4.4.4.4, g=192.168.2.3, len 100, FIB policy routed

Những route không thỏa mãn route-map sẽ forword đi bình thường [do lúc này đã thay ACL 1 chỉ permit 192.168.1.1, nên lúc này sửa lại 192.168.1.2 không thỏa route-,ap forward bình thường]

*Dec 2 15:04:50.923: IP: s=192.168.1.2 (FastEthernet1/1), d=4.4.4.4, len 100, FIB policy rejected(no match) - normal forwarding
*Dec 2 15:04:51.047: IP: s=192.168.1.2 (FastEthernet1/1), d=4.4.4.4, len 100, FIB policy rejected(no match) - normal forwarding
*Dec 2 15:04:51.091: IP: s=192.168.1.2 (FastEthernet1/1), d=4.4.4.4, len 100, FIB policy rejected(no match) - normal forwarding
*Dec 2 15:04:51.127: IP: s=192.168.1.2 (FastEthernet1/1), d=4.4.4.4, len 100, FIB policy rejected(no match) - normal forwarding

Yêu cầu 2.
Nếu packet dài hơn 500 thì ta sẽ cho đi qua R2, còn lại qua R3.

Bây giờ ta bỏ hết route-map trên R1 đi.

R1(config)#no route-map PC0-R2 permi
R1(config)#no route-map PC1-R3 permit
R1(config)#int f1/0
R1(config-if)#no ip policy route-map PC0-R2
R1(config)#int f1/1
R1(config-if)#no ip policy route-map PC1-R3


R1(config)#route-map dodaipacket permit
R1(config-route-map)#match ip address 12 13
R1(config-route-map)#match length 500 2147483647
R1(config-route-map)#set ip next-hop 192.168.2.2

Vì sao chọn 2147483647
R1(config-route-map)#match length ?
<0-2147483647> Minimum packet length

R1(config-route-map)#match length 500 ?


<0-2147483647> Maximum packet length

R1(config-route-map)#match length 500



R1(config)#int f1/0
R1(config-if)#ip policy route-map dodaipacket
R1(config)#int f1/1
R1(config-if)#ip policy route-map dodaipacket

CMD
C:\>ping /?

Usage: ping [-t] [-a] [-n count] [-l size] [-f] [-i TTL] [-v TOS]
[-r count] [-s count] [[-j host-list] | [-k host-list]]
[-w timeout] target_name

Options:
-t Ping the specified host until stopped.
To see statistics and continue - type Control-Br
To stop - type Control-C.
-a Resolve addresses to hostnames.
-n count Number of echo requests to send.
-l size Send buffer size.
-f Set Don't Fragment flag in packet.
-i TTL Time To Live.
-v TOS Type Of Service.
-r count Record route for count hops.
-s count Timestamp for count hops.
-j host-list Loose source route along host-list.
-k host-list Strict source route along host-list.
-w timeout Timeout in milliseconds to wait for each reply.

C:\>ping 4.4.4.4 -l 300

Pinging 4.4.4.4 with 500 bytes of data:

Reply from 4.4.4.4: bytes=500 time=68ms TTL=253
Reply from 4.4.4.4: bytes=500 time=55ms TTL=253
Reply from 4.4.4.4: bytes=500 time=31ms TTL=253
Reply from 4.4.4.4: bytes=500 time=45ms TTL=253

Ping statistics for 4.4.4.4:
Packets: Sent = 4, Received = 4, Lost = 0 (0% l
Approximate round trip times in milli-seconds:
Minimum = 31ms, Maximum = 68ms, Average = 49ms

Debug ip policy trên R1 sẽ thấy bị chuyển qua R2


*Dec 2 15:47:13.655: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4, len 528, FIB policy match
*Dec 2 15:47:13.655: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4, g=192.168.2.2, len 528, FIB policy routed [WinXP]
*Dec 2 15:47:14.651: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4, len 528, FIB policy match
*Dec 2 15:47:14.651: IP: s=192.168.0.1 (FastEthernet1/0), d=4.4.4.4, g=192.168.2.2, len 528, FIB policy routed

*Dec 2 15:49:46.923: IP: s=192.168.1.2 (FastEthernet1/1), d=4.4.4.4, len 600, FIB policy match


*Dec 2 15:49:46.923: IP: s=192.168.1.2 (FastEthernet1/1), d=4.4.4.4, g=192.168.2.2, len 600, FIB policy routed [Router]
*Dec 2 15:49:46.971: IP: s=192.168.1.2 (FastEthernet1/1), d=4.4.4.4, len 600, FIB policy match
*Dec 2 15:49:46.971: IP: s=192.168.1.2 (FastEthernet1/1), d=4.4.4.4, g=192.168.2.2, len 600, FIB policy routed

Độ dài length trong Windows có thể khác độ dài length trong cisco [gói ping]. Cũng như mã hóa MD5 trong cisco và Microsoft cũng có khác biệt. Nhưng nói chung chỉ mục đích thử.

Một số lệnh debug cần thiết.

R1#debug ip policy ?


<1-199> Access list

R1#debug ip icmp

R1#traceroute
R1#show ip policy


Note:
-Đối với lệnh match[tương đương if]
Match ngang: là phép OR.
Vd: match ip address X Y Z thì nếu match một trong những IP này thì sẽ thực hiện lệnh set phía dưới.
Match dọc là phép AND
Vd:
Match ip address X
Match leghth 500 1000
=> gói tin nào có IP match địa chỉ mạng ACL X và có độ dài từ 500 1000 thì sẽ thiết lập packet đó theo lệnh set bên dưới.

-Còn đối với lệnh set [tương đương then] thì sẽ thiết lập thuộc tính của những gói tin đã match.


Và sau đây là mức độ mạnh yếu của lệnh set [càng nhỏ càng mạnh]
1.
R1(config-route-map)#set ip next-hop
R1(config-route-map)#set interface
2.
Tuyến cụ thể. [đó là những tuyến đường trong bảng định tuyến có thể là học từ giao thức khác hoặc những tuyến static]
3.
R1(config-route-map)#set ip default next-hop
R1(config-route-map)#set default interface
4.
Default route
+ S*
+ *D
+ *O
+ Tùy theo AD

Mặc định nếu gói tin đến không match trong route-map thì gói tin sẽ được xử lí tiếp bởi bảng routing theo thứ tự câu lệnh ưu tiên đã nói bên trên.


Nếu muốn gói tin nào không match bị Drop luôn ta có thể dùng lệnh set nằm trong route-map có số sequence lớn nhất.
R1(config)#route-map bogoi permit 500
R1(config-route-map)#set default interface null 0.
Câu lệnh này có tác dụng bất cứ gói nào không match thì sẽ được chuyển vào hết Null 0 [Hủy]

Những gì chúng ta đã làm bên trên tương đương với cái gọi là PBR [policy base routing]




Cơ sở dữ liệu được bảo vệ bởi bản quyền ©hocday.com 2019
được sử dụng cho việc quản lý

    Quê hương